
<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<meta http-equiv="refresh" content="1200">
	<link rel="profile" href="https://gmpg.org/xfn/11">

						<script src="https://cdn.blueconic.net/nexstar.js"></script>
	
	
<!-- BoB -->
<script async type="text/javascript" id="bob_tag_loader">
var page_url = "https:\/\/www.mychamplainvalley.com\/weather\/weather-blogs\/weather-blog-rain-and-snow-returns-midweek\/" || "";
var cats = "Local News,News,SkyTracker Blog,Weather" || "";
var bob_kw = "" || "";
var bob_desc = "Quiet weather continues tonight, but rain and snow return midweek. Plus, we say goodbye to this warm stretch after Turkey Day as temps plummet once again." || "";
var cat_data = "&cats=" + encodeURIComponent(cats) + "&bob_kw=" + encodeURIComponent(bob_kw) + "&bob_desc=" + encodeURIComponent(bob_desc) + "&page_url=" + encodeURIComponent(page_url);

var bob_cb = '1';
bob_cb = ((new Date()).getTime() + "" + Math.floor(Math.random() * 1000000)).substr(0, 16);
(function () {
var bob_tag = document.createElement('script');
bob_tag.type = 'text/javascript';
bob_tag.async = true;
bob_tag.id = "bob_tag";
bob_tag.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'bob.dmpxs.com/static/bob_001.js?bob_cb=' + bob_cb + cat_data;
var bts = document.getElementsByTagName('script')[0];
bts.parentNode.insertBefore(bob_tag, bts);
})();
</script>

<script type="text/javascript" id="bob_003_tag_loader">
var page_url = "https:\/\/www.mychamplainvalley.com\/weather\/weather-blogs\/weather-blog-rain-and-snow-returns-midweek\/" || "";
var video_asset_url = "" || "";

var bob_cb = '1';
bob_cb = ((new Date()).getTime() + "" + Math.floor(Math.random() * 1000000)).substr(0, 16);
(function() {
var bob_tag_003 = document.createElement('script');
bob_tag_003.type = 'text/javascript';
bob_tag_003.id = "bob_tag_003";
bob_tag_003.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'bob.dmpxs.com/static/bob_003.js?bob_cb=' + bob_cb + '&page_url=' + page_url  + '&vid_asset_url=' + video_asset_url;
var bts_003 = document.getElementsByTagName('script')[0];
bts_003.parentNode.insertBefore(bob_tag_003,bts_003);
})();
</script>

				
<!-- Index Exchange -->
<script async src="https://js-sec.indexww.com/ht/p/184979-164251977320883.js"></script> 	
				
<!-- A9 APS -->
<script type="text/javascript">
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

apstag.init({"pubID":"3410","adServer":"googletag"});
</script>
	
				
<!-- Confiant ad fraud protection -->
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/Y2Nn8JmiAY8HpnF4sl5n7J71jaI/gpt_and_prebid/config.js"></script> 	
	
<script type="text/javascript">
(function() {
	var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
	_sf_async_config.uid = "23192";
	_sf_async_config.domain = "mychamplainvalley.com";
	_sf_async_config.flickerControl = false; 	_sf_async_config.useCanonical = true;
	_sf_async_config.useCanonicalDomain = true;
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>

	
<!-- Google Publisher Tag -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<!-- End Google Publisher Tag -->


	
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',"GTM-KJJZHXD");</script>
<!-- End Google Tag Manager -->

	
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',"GTM-57QJFQ");</script>
<!-- End Google Tag Manager -->

	
	<title>Weather Blog: Rain and snow returns midweek</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Local 22/44 News &raquo; Feed" href="https://www.mychamplainvalley.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Local 22/44 News &raquo; Comments Feed" href="https://www.mychamplainvalley.com/comments/feed/" />
<script class="wp-asset-manager page_attributes" type="text/javascript">window.amScripts = window.amScripts || {}; window.amScripts["page_attributes"] = {"page_url":"https:\/\/www.mychamplainvalley.com\/weather\/weather-blogs\/weather-blog-rain-and-snow-returns-midweek\/","page_slug":"weather-blog-rain-and-snow-returns-midweek","page_type":"story","page_category":"skytracker_blog","article_id":162306,"subpath":"\/weather\/skytracker_blog"}</script><script class="wp-asset-manager ns-ad-loader-js" type="text/javascript">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</script><meta name='description' content='Quiet weather continues tonight, but rain and snow return midweek. Plus, we say goodbye to this warm stretch after Turkey Day as temps plummet once again.' /><!-- WP SEO -->
<meta name='google-site-verification' content='4m5jRakfjObSlLPQSz8zgz8Z8KaVFKRs9D1N4Bg7Fts' /><!-- WP SEO -->
<meta name='google-site-verification' content='XpGXax1Jpn7GtFNq4trn14yMC8oJCqPjENETs12BBSY' /><!-- WP SEO -->
<meta name='google-site-verification' content='Hb5Wi86B46i8Nyc-yk8qbt5SVIUIuRdk0vBXrW41dH8' /><!-- WP SEO -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mychamplainvalley.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style>
	:root {
		--primary_color: #136ADB;
		--alert_banner_label_sep: '/';
	}
</style>
<link rel='stylesheet' id='all-css-0' href='https://www.mychamplainvalley.com/wp-includes/css/dist/block-library/style.min.css?m=1571091488g' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='ns-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lora%3A400%2C400i%2C700%2C700i%7CRoboto+Condensed%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://www.mychamplainvalley.com/_static/??-eJyVjEEOwiAQRS9kGaAVdGF6lmEYKwqUFBo9vq1x6cbFT15+Xh48S0dzbpwbtBsnrpD5VRsuQDHsr1tD9EC1whRnh1HIgR1K55W02httCN1JpJDF5hzgjx4uLVBkgaQtkUJrkK6S5Tb1M5jWrsR1CrnCnVtBenw6X971MV3U0Q6mN/15eAMd202T' type='text/css' media='all' />
<style id='ns-article-css-inline-css' type='text/css'>
.article--is-condensed .article-content { max-height: 600px; }
</style>
<script type='text/javascript' src='https://www.mychamplainvalley.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZdVrKOPT4FubmZ6UWJJql5uZh5QsX2uraGpuaGBpaGJhWUWACWDILM='></script>
<link rel='https://api.w.org/' href='https://www.mychamplainvalley.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mychamplainvalley.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mychamplainvalley.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.4" />
<link rel="canonical" href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-and-snow-returns-midweek/" />
<link rel='shortlink' href='https://www.mychamplainvalley.com/?p=162306' />
<link rel="alternate" type="application/json+oembed" href="https://www.mychamplainvalley.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mychamplainvalley.com%2Fweather%2Fweather-blogs%2Fweather-blog-rain-and-snow-returns-midweek%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mychamplainvalley.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mychamplainvalley.com%2Fweather%2Fweather-blogs%2Fweather-blog-rain-and-snow-returns-midweek%2F&#038;format=xml" />
<style id="lakana-art-direction"></style>
			<meta property="fb:pages" content="133231890662" />
			<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript" src=""></script><link rel="amphtml" href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-and-snow-returns-midweek/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Weather Blog: Rain and snow returns midweek" />
<meta property="og:url" content="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-and-snow-returns-midweek/" />
<meta property="og:description" content="Quiet weather continues tonight, but rain and snow return midweek. Plus, we say goodbye to this warm stretch after Turkey Day as temps plummet once again." />
<meta property="article:published_time" content="2019-11-26T22:33:02+00:00" />
<meta property="article:modified_time" content="2019-11-26T22:33:03+00:00" />
<meta property="og:site_name" content="Local 22/44 News" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Weather Blog: Rain and snow returns midweek" />
<meta name="twitter:image" content="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="og:image" content="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=1280&amp;h=720&amp;crop=1" />
<meta property="og:image:secure_url" content="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=1280&#038;h=720&#038;crop=1" />
<meta name="twitter:title" content="Weather Blog: Rain and snow returns midweek" />
<meta name="twitter:description" content="Quiet weather continues tonight, but rain and snow return midweek. Plus, we say goodbye to this warm stretch after Turkey Day as temps plummet once again." />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/06/apple-touch-icon-ipad-retina.png?w=32" sizes="32x32" />
<link rel="icon" href="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/06/apple-touch-icon-ipad-retina.png?w=152" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/06/apple-touch-icon-ipad-retina.png?w=152" />
<meta name="msapplication-TileImage" content="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/06/apple-touch-icon-ipad-retina.png?w=152" />
</head>

<body class="post-template-default single single-post postid-162306 single-format-standard wp-custom-logo">
	
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KJJZHXDheight="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

	
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-57QJFQheight="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

	<div id="page" class="site">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
	<div class="site-header__content">
					<p class="screen-reader-text"><a href="https://www.mychamplainvalley.com/" rel="home">Local 22/44 News</a></p>
		
		<div class="site-header__branding">
			<div class="site-header__branding__content">
				<div class="site-header__logo">
					<a href="https://www.mychamplainvalley.com/" rel="home">
						<img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/05/mychamplainvalley_digitalbrand-min.png" alt="SkyTracker Blog" />
						<div class="site-header__logo-bg" style="background-image: url('https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/05/mychamplainvalley_digitalbrand-min.png');"></div>
					</a>
				</div>
				<div class="site-header__weather">
											<a href="https://www.mychamplainvalley.com/weather/">
							<span class="site-header__weather-region">Colchester</span>
							<span class="site-header__weather-forecast">
								<span class="site-header__weather-forecast__text">50&deg;</span>
								<figure class="site-header__weather-forecast__icon">
									<span class="weather-icon weather-icon-sm weather-icon-light-98"></span>
								</figure>
							</span>
						</a>
									</div>
				<div class="site-header__widget">
					<div class="site-header__sponsor">
						<aside class="ad-unit ad-unit--microbar ad-unit--microbar--header">
															<span class="ad_unit__label">Sponsored By</span>
														<div class="ad-unit__content">
								  <div   id="acm-ad-tag-header-microbar-header-microbar"   data-slot='{"pos":"header-microbar","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[88,31],"sizes":[[[900,0],[[88,31]]],[[0,0],[]]],"amp_multi_size":"88x31","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"header-microbar","tag_id":"header-microbar","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"header-microbar","fold":"atf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-header-microbar-header-microbar'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  							</div>
						</aside>

					</div>
					<button class="site-header__toggle" aria-controls="supernav" aria-expanded="false">
						<span class="screen-reader-text">Toggle Menu</span>
						<span class="icon icon--navicon">
							
<svg aria-hidden="true" tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 19.969 12.063">
	<title>Open Navigation</title>
	<path fill="#fff" d="M.793 1.556h18.363a.778.778 0 1 0 0-1.555H.793a.854.854 0 0 0-.809.778.73.73 0 0 0 .809.777zm18.363 3.695H.793a.778.778 0 1 0 0 1.555h18.363a.778.778 0 1 0 0-1.555zm0 5.25H.793a.779.779 0 1 0 0 1.556h18.363a.779.779 0 1 0 0-1.557z" />
</svg>
						</span>
						<span class="icon icon--close">
							
<svg aria-hidden="true" tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16.85 16.875">
	<title>Close Navigation</title>
	<path fill="#fff" d="M9.65 8.454l6.88-7.063a.809.809 0 0 0 0-1.15.782.782 0 0 0-1.14 0L8.52 7.305 1.37.241a.782.782 0 0 0-1.14 0 .809.809 0 0 0 0 1.15l7.15 7.063-7.15 7.063a.809.809 0 0 0 0 1.15.824.824 0 0 0 .6.219.787.787 0 0 0 .59-.219l7.15-7.063 6.87 7.063a.824.824 0 0 0 .6.219.619.619 0 0 0 .54-.219.792.792 0 0 0 0-1.15z" />
</svg>
						</span>
					</button>
				</div>
			</div>
		</div>

		<nav id="siteNavigation" class="site-header__navigation">
			<div class="site-header__search-full">
				
<form role="search" class="site-header__search-form" action="https://www.mychamplainvalley.com/">
	<span class="screen-reader-text">Search</span>
	<input type="search" name="s" placeholder="Site Search..." />
	<input type="submit" name="submit" value="" />
</form>
			</div>

			<div class="site-header__navigation__content">
				<h2 class="screen-reader-text">Primary Menu</h2>


				<ul id="supernav" class="menu">
	<li id="menu-item-158049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158049"><a href="https://www.mychamplainvalley.com/news/">News</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-158051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158051"><a href="https://www.mychamplainvalley.com/news/local-news/">Local News</a></li>
	<li id="menu-item-158052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158052"><a href="https://www.mychamplainvalley.com/news/vermont/">Vermont</a></li>
	<li id="menu-item-158053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158053"><a href="https://www.mychamplainvalley.com/news/new-hampshire/">New Hampshire</a></li>
	<li id="menu-item-158050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158050"><a href="https://www.mychamplainvalley.com/news/new-york/">New York</a></li>
	<li id="menu-item-158054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158054"><a href="https://www.mychamplainvalley.com/video/">Video</a></li>
	<li id="menu-item-158060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158060"><a href="https://www.mychamplainvalley.com/what-matters-this-week/">What Matters This Week</a></li>
	<li id="menu-item-158057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158057"><a href="https://www.mychamplainvalley.com/news/2020-election/">2020 Election</a></li>
	<li id="menu-item-158061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158061"><a href="https://www.mychamplainvalley.com/news/national-news/">National News</a></li>
	<li id="menu-item-158062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158062"><a href="https://www.mychamplainvalley.com/news/morning-show/">Morning Brew</a></li>
	<li id="menu-item-158063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158063"><a href="https://www.mychamplainvalley.com/news/veterans-voices/">Veterans Voices</a></li>
	<li id="menu-item-158138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158138"><a href="https://www.mychamplainvalley.com/story-idea/">Submit a Story Idea</a></li>
</ul>
</div></div></li>
<li id="menu-item-158064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158064"><a href="https://www.mychamplainvalley.com/weather/">Weather</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-158072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158072"><a href="https://www.mychamplainvalley.com/weather/latest-forecast/">Latest Forecast</a></li>
	<li id="menu-item-158067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158067"><a href="https://www.mychamplainvalley.com/weather-map/">Weather Map</a></li>
	<li id="menu-item-158065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158065"><a href="https://www.mychamplainvalley.com/weather/ski-report/">Ski Report</a></li>
	<li id="menu-item-158070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158070"><a href="https://www.mychamplainvalley.com/weather/weather-blogs/">SkyTracker Blog</a></li>
	<li id="menu-item-158071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158071"><a href="https://www.mychamplainvalley.com/weather/skytracker-cam/">SkyTracker Cam</a></li>
	<li id="menu-item-158066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158066"><a href="https://www.mychamplainvalley.com/skytracker-weather-team-school-visits/">SkyTracker Weather Team School Visits</a></li>
	<li id="menu-item-158073" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158073"><a href="https://www.mychamplainvalley.com/weather/flight-delays/">Flight Delays</a></li>
</ul>
</div></div></li>
<li id="menu-item-158097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158097"><a href="https://www.mychamplainvalley.com/sports/">Sports</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-158096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158096"><a href="https://www.mychamplainvalley.com/sports/local-sports/">Local Sports</a></li>
	<li id="menu-item-158094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158094"><a href="https://www.mychamplainvalley.com/sports/college-sports/">College Sports</a></li>
	<li id="menu-item-158095" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158095"><a href="https://www.mychamplainvalley.com/sports/high-school-sports/">High School Sports</a></li>
	<li id="menu-item-159244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159244"><a href="https://www.mychamplainvalley.com/athlete-of-the-week/">Athlete of the Week</a></li>
	<li id="menu-item-159245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159245"><a href="https://www.mychamplainvalley.com/catamount-country-sports/">Catamount Country Sports</a></li>
</ul>
</div></div></li>
<li id="menu-item-158090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158090"><a href="https://www.mychamplainvalley.com/nfl/">NFL</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-158087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158087"><a href="https://www.mychamplainvalley.com/new-england-nation/">New England Nation</a></li>
	<li id="menu-item-159257" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159257"><a href="https://www.mychamplainvalley.com/new-york-blitz/">NY Blitz</a></li>
	<li id="menu-item-158092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158092"><a href="https://www.mychamplainvalley.com/sports/the-big-game/">The Big Game</a></li>
	<li id="menu-item-158093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158093"><a href="https://www.mychamplainvalley.com/pro-football-challenge/">Pro Football Challenge</a></li>
</ul>
</div></div></li>
<li id="menu-item-158103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158103"><a href="https://www.mychamplainvalley.com/marketplace/">Living Local</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-162170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162170"><a href="https://www.mychamplainvalley.com/feed-a-family-2/">Feed a Family</a></li>
	<li id="menu-item-158104" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158104"><a href="https://www.mychamplainvalley.com/the-mel-robbins-show/">The Mel Robbins Show</a></li>
	<li id="menu-item-158106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158106"><a href="https://www.mychamplainvalley.com/forever-home/">Forever Home</a></li>
	<li id="menu-item-159243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159243"><a href="https://www.mychamplainvalley.com/at-the-box-office/">At the Box Office</a></li>
	<li id="menu-item-158109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158109"><a href="https://www.mychamplainvalley.com/vermont-historical-society/">This Place in History</a></li>
	<li id="menu-item-159240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159240"><a href="https://www.mychamplainvalley.com/44s-finest-2/">44&#8217;s Finest</a></li>
	<li id="menu-item-158113" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158113"><a href="https://www.mychamplainvalley.com/calendar/">Calendar</a></li>
	<li id="menu-item-158117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158117"><a href="https://www.mychamplainvalley.com/tv-schedule/">TV Schedule</a></li>
	<li id="menu-item-158110" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158110"><a href="https://www.mychamplainvalley.com/marketplace/ski-ride-card/">Ski &#038; Ride Card</a></li>
	<li id="menu-item-158608" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158608"><a href="https://www.mychamplainvalley.com/marketplace/burlington-dining-card/">Burlington Dining Card</a></li>
	<li id="menu-item-158112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158112"><a href="https://www.mychamplainvalley.com/marketplace/northeast-kingdom-dining-card/">Northeast Kingdom Dining Card</a></li>
	<li id="menu-item-158118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158118"><a href="https://www.mychamplainvalley.com/marketplace/plattsburgh-dining-card/">Plattsburgh Dining Card</a></li>
</ul>
</div></div></li>
<li id="menu-item-159246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-159246"><a href="https://www.mychamplainvalley.com/experts/">Experts</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-159247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159247"><a href="https://www.mychamplainvalley.com/experts/banking-finance-expert/">Local Financial Expert</a></li>
	<li id="menu-item-159248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159248"><a href="https://www.mychamplainvalley.com/experts/fitness-expert/">Local Fitness Expert</a></li>
	<li id="menu-item-159249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159249"><a href="https://www.mychamplainvalley.com/experts/gardening-expert/">Local Gardening Expert</a></li>
	<li id="menu-item-159250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159250"><a href="https://www.mychamplainvalley.com/experts/beans-mobile-homes/">Local Modular Home Expert</a></li>
	<li id="menu-item-159251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159251"><a href="https://www.mychamplainvalley.com/experts/sleep-expert/">Local Sleep Expert</a></li>
	<li id="menu-item-159252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159252"><a href="https://www.mychamplainvalley.com/experts/local-trades-expert/">Local Trades Expert</a></li>
</ul>
</div></div></li>
<li id="menu-item-158495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158495"><a href="https://www.mychamplainvalley.com/contests/">Contests</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-158132" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158132"><a href="https://www.mychamplainvalley.com/turkey-day-giveaway/">Turkey Day Giveaway</a></li>
	<li id="menu-item-160279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-160279"><a href="https://www.mychamplainvalley.com/stowe-for-the-holidays/">Stowe for the Holidays</a></li>
	<li id="menu-item-158130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158130"><a href="https://www.mychamplainvalley.com/pro-football-challenge/">Pro Football Challenge</a></li>
	<li id="menu-item-158131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158131"><a href="https://www.mychamplainvalley.com/2019-contest-winners/">2019 Contest Winners</a></li>
</ul>
</div></div></li>
<li id="menu-item-159253" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-159253"><a href="https://www.mychamplainvalley.com/unscripted/">Brit Unscripted</a>
<div class="dropnav dropnav--1-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="1">
	<li id="menu-item-159254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159254"><a href="https://www.mychamplainvalley.com/unscripted/brits-beauty-tips/">Brit&#8217;s Beauty Tips</a></li>
	<li id="menu-item-159255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159255"><a href="https://www.mychamplainvalley.com/unscripted/brits-beauty-trends/">Brit&#8217;s Beauty Trends</a></li>
	<li id="menu-item-159256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-159256"><a href="https://www.mychamplainvalley.com/unscripted/get-fit-with-brit/">Get Fit with Brit</a></li>
</ul>
</div></div></li>
<li id="menu-item-159242" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-159242"><a href="https://www.mychamplainvalley.com/aboutus/">About Us</a>
<div class="dropnav dropnav--2-col">
	<div class="dropnav__section dropnav__section--sub-menu">
		<ul class="sub-menu" data-columns="2">
	<li id="menu-item-161758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161758"><a href="https://www.mychamplainvalley.com/aboutus/contact-us/">Contact Information</a></li>
	<li id="menu-item-158136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158136"><a href="https://www.mychamplainvalley.com/aboutus/advertise-with-us/">Advertise with Us</a></li>
	<li id="menu-item-158135" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158135"><a href="https://www.mychamplainvalley.com/local-44-news-team/">Meet the Team</a></li>
	<li id="menu-item-161880" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161880"><a href="https://www.mychamplainvalley.com/aboutus/work-for-us/">Work for Us</a></li>
	<li id="menu-item-158137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158137"><a href="https://www.mychamplainvalley.com/aboutus/wvny-wfff-closed-captioning/">Closed Captioning</a></li>
	<li id="menu-item-158144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158144"><a href="https://www.mychamplainvalley.com/aboutus/station-tours/">Station Tours</a></li>
	<li id="menu-item-158145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158145"><a href="https://www.mychamplainvalley.com/aboutus/internships/">Local 22 &#038; Local 44 Internships</a></li>
	<li id="menu-item-158146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158146"><a href="https://www.mychamplainvalley.com/aboutus/mobileapp/">Local 22 &#038; Local 44 Mobile App</a></li>
</ul>
</div></div></li>
</ul>

				<div class="site-header__search-drop">
					<a class="site-header__search-drop__toggle" href="#">
						<span class="screen-reader-text">Search</span>
						<span class="icon">
							
<svg  aria-hidden="true" tabindex="-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 17">
	<title>Search</title>
	<path d="M15.72 15.4l-3.75-3.8a7 7 0 0 0 1.72-4.612 6.851 6.851 0 1 0-6.85 6.98 6.713 6.713 0 0 0 3.72-1.127l3.85 3.9a.9.9 0 0 0 .65.276.92.92 0 0 0 .66-.276.965.965 0 0 0 0-1.341zM1.85 6.984a4.991 4.991 0 1 1 4.99 5.087 5.036 5.036 0 0 1-4.99-5.09z" />
</svg>
						</span>
					</a>
					
<form role="search" class="site-header__search-form" action="https://www.mychamplainvalley.com/">
	<span class="screen-reader-text">Search</span>
	<input type="search" name="s" placeholder="What are you looking for?" />
	<input type="submit" name="submit" value="Search" />
</form>
				</div>
			</div>
		</nav>
	</div>
</header>

		<div class="site-content-wrapper">
			
<div class="alert-banners js-alert-banners has-messages">
	
	<div class="weather-alerts" data-react-component="WeatherAlerts"></div>
</div>


			
<div id="content" class="site-content">
	<aside class="ad-unit ad-unit--leaderboard">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-billboard1-billboard1"   data-slot='{"pos":"billboard1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[320,50],"sizes":[[[1280,0],[[728,90],[970,250],[970,90],[970,30]]],[[1024,0],[[728,90],[970,250],[970,90],[970,30]]],[[768,0],[[728,90]]],[[641,0],[[320,50]]],[[0,0],[[320,50]]]],"amp_multi_size":"320x50","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"billboard1","tag_id":"billboard1","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"billboard1","fold":"atf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-billboard1-billboard1'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>

	
	
	<div class="site-content__layout site-content__layout--has-sidebar">
		
		
		
		<div id="primary" class="content-area">
			<main id="main" class="site-main">

				
<article class="article post-162306 post type-post status-publish format-standard has-post-thumbnail hentry category-local-news category-news category-weather-blogs category-weather" data-component="article">
	
<header class="article-header">
	<h1 class="article-title">
		Weather Blog: Rain and snow returns midweek	</h1>

			<div class="article-eyebrow">
			<a href="https://www.mychamplainvalley.com/weather/weather-blogs/">SkyTracker Blog</a>
		</div>
	
	
	<div class="article-meta">
					<p>by: <a href="https://www.mychamplainvalley.com/author/amanda-thibault/" title="Posts by Amanda Thibault" class="author url fn" rel="author">Amanda Thibault</a></p>
		
					Posted: <time datetime="2019-11-26T17:33:02-05:00">Nov 26, 2019 / 05:33 PM EST</time>		
					<span class="article-meta--sep"> / </span>Updated: <time datetime="2019-11-26T17:33:03-05:00">Nov 26, 2019 / 05:33 PM EST</time>			</div><!-- .article-meta -->

			<figure class="article-featured-media article-featured-media--is-image">
			
<div class="image-wrapper landscape">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</figure>
	
	<div class="article-lead-share">
		
<div class="social-share addthis">
	<div class="addthis_inline_share_toolbox"></div>
</div>
	</div>
</header><!-- .article-header -->

	
	<div class="article-content rich-text">
		
<ul class="wp-block-gallery columns-3 is-cropped"><li class="blocks-gallery-item"><figure><img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?w=900" alt="" data-id="162313" data-link="https://www.mychamplainvalley.com/?attachment_id=162313" class="wp-image-162313" srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=300,169 300w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=768,432 768w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=1024,576 1024w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=320,180 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=640,360 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=960,540 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tonight-16.jpg?resize=1280,720 1280w" sizes="(max-width: 1920px) 100vw, 1920px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?w=900" alt="" data-id="162311" data-link="https://www.mychamplainvalley.com/?attachment_id=162311" class="wp-image-162311" srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=300,169 300w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=768,432 768w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=1024,576 1024w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=320,180 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=640,360 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=960,540 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/tgiving.jpg?resize=1280,720 1280w" sizes="(max-width: 1920px) 100vw, 1920px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?w=900" alt="" data-id="162307" data-link="https://www.mychamplainvalley.com/?attachment_id=162307" class="wp-image-162307" srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=300,169 300w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=768,432 768w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=1024,576 1024w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=320,180 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=640,360 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=960,540 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wed5pm.jpg?resize=1280,720 1280w" sizes="(max-width: 1920px) 100vw, 1920px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?w=900" alt="" data-id="162308" data-link="https://www.mychamplainvalley.com/?attachment_id=162308" class="wp-image-162308" srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=300,169 300w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=768,432 768w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=1024,576 1024w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=320,180 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=640,360 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=960,540 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/thurs5am-1.jpg?resize=1280,720 1280w" sizes="(max-width: 1920px) 100vw, 1920px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?w=900" alt="" data-id="162310" data-link="https://www.mychamplainvalley.com/?attachment_id=162310" class="wp-image-162310" srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=300,169 300w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=768,432 768w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=1024,576 1024w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=320,180 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=640,360 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=960,540 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/rainfall-2.jpg?resize=1280,720 1280w" sizes="(max-width: 1920px) 100vw, 1920px" /></figure></li><li class="blocks-gallery-item"><figure><img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?w=900" alt="" data-id="162309" data-link="https://www.mychamplainvalley.com/?attachment_id=162309" class="wp-image-162309" srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=300,169 300w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=768,432 768w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=1024,576 1024w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=320,180 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=640,360 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=960,540 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/snowfall-5.jpg?resize=1280,720 1280w" sizes="(max-width: 1920px) 100vw, 1920px" /></figure></li></ul>



<p>Good evening!</p>



<p>Quiet weather continues tonight, but rain and snow return midweek. Plus, we say goodbye to this warm stretch after Turkey Day as temps plummet once again. Let&#8217;s break it down day-by-day.</p>



<p>Tuesday Night &#8211; Mostly cloudy with a low temp in the upper 20s to low and mid 30s. Light south wind becoming light and variable.</p>



<p>Wednesday &#8211; Mostly cloudy, but mainly dry in the morning. By the afternoon, scattered rain moves in. A few late afternoon or early evening downpours may be possible. In total, expect 0.25-0.75&#8243; rainfall. The temp reaches into the 40s with a south breeze of 5-15 mph.</p>



<p>Wednesday Night &#8211; As the temp falls into the low 30s, rain will mix with or change over to snow, depending on elevation. That breezy south wind will shift to out of the north as a cold front slides by.</p>



<p>Thanksgiving Thursday &#8211; Scattered rain and snow showers remain during the morning with temps rebounding into the mid to upper 30s. Then, falling temps in the afternoon facilitate a complete switchover to scattered, very hit-or-miss snow showers. In totals, valleys should expect no accumulation to around a dusting. At 1000-2000&#8242;, a dusting to 1-2&#8243; is possible. Mountain summits, above 3000&#8242; could get 4-6&#8243;. North wind 10-20 mph with gusts to 30-35 mph.</p>



<p>Friday &#8211; Slowly clearing and colder. Morning temps in the 20s, afternoon high around 30 degrees.</p>



<p>Saturday &#8211; Mostly sunny. Teens in the morning and also Saturday night with a high temp in between in the upper 20s.</p>



<p>Our next weather maker likely brings accumulating snow to southern Vermont and New Hampshire, passing largely to our south. Details are still not locked in with this one, but confidence is growing daily so keep checking back with us for updates!</p>



<p>Have a fantastic Wednesday!</p>



<p>-Skytracker Chief Meteorologist Amanda Thibault</p>

		
	</div><!-- .rich-text -->

	
<footer class="article-footer">
			<p class="article-copyright">Copyright 2019 Nexstar Broadcasting, Inc. All rights reserved. This material may not be published, broadcast, rewritten, or redistributed.</p>
	
	<div class="article-footer-share">
					<h2 class="article-footer-share__heading">Share this story</h2>
				
<div class="social-share addthis">
	<div class="addthis_inline_share_toolbox"></div>
</div>
	</div>
</footer><!-- .article-footer -->

	<section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><div id="lkqd-outstream"></div></div></div></section></article>

<aside class="ad-unit ad-unit--mr1-mobile">
	<div class="ad-unit__content">
		  <div   id="acm-ad-tag-mr1_mobile-mr1_mobile"   data-slot='{"pos":"mr1_mobile","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[900,0],[]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"mr1_mobile","tag_id":"mr1_mobile","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"mr1_mobile","fold":"atf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr1_mobile-mr1_mobile'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  	</div>
</aside>


	<div
		id="widget1"
		data-rc-widget
		data-widget-host="habitat"
		data-endpoint="trends.revcontent.com"
		data-widget-id="114891"
	></div>
	<script src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script> 	
	<aside class="article-list article-list--full-width">
		
	<h2 class="article-list__heading article-list__heading--notched">
		More SkyTracker Blog Stories	</h2>


<div class="article-list__content">
						<a class="article-list__blanketing-link" href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-snow-moves-in-just-in-time-for-thanksgiving-travel-heres-what-to-expect/">
		
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--has-excerpt"
			data-index="0"
			data-collection="article-list1"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list1"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
			
				Weather Blog: Rain &amp; Snow moves in just in time for Thanksgiving travel. Here&#8217;s what to expect.
					</h3>
	
			<footer class="article-list__article-byline">
			by Haley Bouley <span class="sep">/</span> <time datetime="2019-11-26T08:47:11-05:00">Nov 26, 2019</time>		</footer>
	
			<div class="article-list__article-excerpt article-list__article-excerpt--is-faded rich-text">
			<p>Nothing to really worry about weatherwise today, expect a mix of sun and clouds with a few stray sprinkles along the international border. Temps are feeling spring-like, climbing into the upper 40's to low 50's.</p>
<p>Messy weather will be impacting your thanksgiving plans. Let's break it down for you so you know what to expect!</p>
		</div>
	
			<div class="article-list__read-more article-list__read-more--w-arrow">
							<span>
					Read the Full Article
											<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
									</span>
					</div>
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape">
	<img
		src="https://i2.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://i2.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/turkey-travel.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

			</figure>
			</article>

					</a>
								<a class="article-list__blanketing-link" href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-finally-warmer-for-a-few-days/">
		
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--has-excerpt"
			data-index="1"
			data-collection="article-list1"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list1"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
			
				Weather Blog: Finally warmer for a few days
					</h3>
	
			<footer class="article-list__article-byline">
			by Amanda Thibault <span class="sep">/</span> <time datetime="2019-11-25T16:34:04-05:00">Nov 25, 2019</time>		</footer>
	
			<div class="article-list__article-excerpt article-list__article-excerpt--is-faded rich-text">
			<p>Good evening!</p>
<p>Quieter and warmer weather takes us right through Wednesday morning with rain arriving on Wednesday afternoon. By Thanksgiving, it's cooler again and scattered snow showers linger through much of Turkey Day.</p>
		</div>
	
			<div class="article-list__read-more article-list__read-more--w-arrow">
							<span>
					Read the Full Article
											<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
									</span>
					</div>
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TUES-3.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

			</figure>
			</article>

					</a>
								<a class="article-list__blanketing-link" href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-quiet-weather-comes-to-an-end-just-in-time-for-holiday-travel/">
		
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--has-excerpt"
			data-index="2"
			data-collection="article-list1"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list1"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
			
				Weather Blog: Quiet weather comes to an end just in time for holiday travel
					</h3>
	
			<footer class="article-list__article-byline">
			by Haley Bouley <span class="sep">/</span> <time datetime="2019-11-25T09:42:32-05:00">Nov 25, 2019</time>		</footer>
	
			<div class="article-list__article-excerpt article-list__article-excerpt--is-faded rich-text">
			<p>After a very unsettled weather day Sunday, we're starting off this work week on a quiet note! </p>
<p>Speaking of Sunday... It was a mess, wasn't it! If you live in Western Vermont and the North Country of New York move on to the next paragraph.. you barely saw flurries! But in Eastern Vermont, the snow, the sleet, the freezing rain, and the rain all caused issues on the roadways!</p>
		</div>
	
			<div class="article-list__read-more article-list__read-more--w-arrow">
							<span>
					Read the Full Article
											<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
									</span>
					</div>
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/wednesday-1.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

			</figure>
			</article>

					</a>
			</div>


	</aside>
	
<aside class="ad-unit ad-unit--leader-mr1">
	<div class="ad-unit__content">
		  <div   id="acm-ad-tag-leader_mr1-leader_mr1-story-pages"   data-slot='{"pos":"leader_mr1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1152,0],[[728,90]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leader_mr1","tag_id":"leader_mr1 Story pages","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"leader_mr1","fold":"btf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leader_mr1-leader_mr1-story-pages'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  	</div>
</aside>

	<aside class="article-list article-list--grid article-list--grid-2">
		
	<h2 class="article-list__heading article-list__heading--notched">
		More Stories	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-index="0"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/local-officials-promote-small-business-saturday/"
									>
			
				Local officials promote Small Business Saturday
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/news/">News</a> / <time datetime="2019-11-26T18:46:48-05:00">26 mins ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.mychamplainvalley.com/news/local-officials-promote-small-business-saturday/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape square-on-mobile">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?resize=1920%2C1080&amp;ssl=1 1920w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/smal00_00_42_51.Still001.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

							
<span aria-hidden="true" tabindex="-1" class="article-list__article-mediaicon">
	<span class="article-list__article-mediaicon-svg">
		<svg viewBox="0 0 24 24">
			<path d="M8,5.14V19.14L19,12.14L8,5.14Z" />
		</svg>
	</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

					
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-index="1"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/local-news/missing-chateaugay-teen-found-dead/"
									>
			
				Missing Chateaugay teen found dead
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/news/local-news/">Local News</a> / <time datetime="2019-11-26T16:14:48-05:00">3 hours ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.mychamplainvalley.com/news/local-news/missing-chateaugay-teen-found-dead/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper portrait square-on-mobile">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?resize=1440%2C2560&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?w=180&amp;h=320&amp;crop=1 180w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?resize=360%2C640&amp;ssl=1 360w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?resize=540%2C960&amp;ssl=1 540w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?resize=720%2C1280&amp;ssl=1 720w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?resize=1080%2C1920&amp;ssl=1 1080w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/MISSING-SEXTON.jpg?resize=1440%2C2560&amp;ssl=1 1440w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

					
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-index="2"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/local-news/vermont-begins-process-of-seeking-go-ahead-to-import-prescription-drugs/"
									>
			
				Vermont begins process of seeking go-ahead to import prescription drugs
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/news/local-news/">Local News</a> / <time datetime="2019-11-26T15:21:06-05:00">4 hours ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.mychamplainvalley.com/news/local-news/vermont-begins-process-of-seeking-go-ahead-to-import-prescription-drugs/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape square-on-mobile">
	<img
		src="https://i1.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?w=320&amp;h=180&amp;crop=1 320w, https://i1.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?resize=640%2C360&amp;ssl=1 640w, https://i1.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?resize=960%2C540&amp;ssl=1 960w, https://i1.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?resize=1280%2C720&amp;ssl=1 1280w, https://i1.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?resize=1920%2C1080&amp;ssl=1 1920w, https://i1.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/08/149a52ec5f1846c797a78b956e32c331.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

					
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-index="3"
			data-collection="article-list2"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list2"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/new-hampshire/new-hampshire-poised-to-join-states-that-allow-sports-betting/"
									>
			
				New Hampshire poised to join states that allow sports betting
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/news/new-hampshire/">New Hampshire</a> / <time datetime="2019-11-26T14:46:11-05:00">4 hours ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb">
					<a
				href="https://www.mychamplainvalley.com/news/new-hampshire/new-hampshire-poised-to-join-states-that-allow-sports-betting/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape square-on-mobile">
	<img
		src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=2560&#038;h=1440&#038;crop=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/sports_betting.jpg?w=2560&amp;h=1440&amp;crop=1 2560w"
		sizes="(max-width: 899px) 100%, (max-width: 1023px) 75vw, 884px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

			</div>

	<div class="article-list__read-more article-list__read-more--w-arrow">
		<a href="/news/">
			Read more stories
							<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
					</a>
	</div>
	
	</aside>
	
			</main>
		</div>

		
<section id="secondary" class="widget-area">
	<!-- Ad Unit Square -->
	<aside class="ad-unit ad-unit--square">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-mr_combo1-mr_combo1"   data-slot='{"pos":"mr_combo1","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1280,0],[[300,600],[300,250]]],[[1024,0],[[300,600],[300,250]]],[[768,0],[[300,250]]],[[641,0],[[300,250]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"mr_combo1","tag_id":"mr_combo1","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"mr_combo1","fold":"atf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr_combo1-mr_combo1'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>
	<!-- END Ad Unit Square -->

	<section id="ns-article-bin-36" class="widget widget_ns-article-bin">				<section
					class="article-list article-list--story-grid article-list--story-grid--one-col"
					data-component=""
					data-context="headline_list"
				>
					
	<h2 class="article-list__heading">
		Sports	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-index="0"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/sports/uvm-womens-hockey-confident-in-bounce-back-ability/"
									>
			
				UVM women&#8217;s hockey confident in bounce-back ability
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/sports/">Sports</a> / <time datetime="2019-11-25T18:54:05-05:00">1 day ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
					<a
				href="https://www.mychamplainvalley.com/sports/uvm-womens-hockey-confident-in-bounce-back-ability/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?resize=1920%2C1080&amp;ssl=1 1920w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/1125-uvm-whoc.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, 300px"
	/>
</div>

							
<span aria-hidden="true" tabindex="-1" class="article-list__article-mediaicon">
	<span class="article-list__article-mediaicon-svg">
		<svg viewBox="0 0 24 24">
			<path d="M8,5.14V19.14L19,12.14L8,5.14Z" />
		</svg>
	</span>
	</span>
					</div>

					</a>
			</figure>
			</article>

					
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-index="1"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/sports/bu-downs-vermont-5-1-for-series-sweep/"
									>
			
				BU downs Vermont 5-1 for series sweep
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/sports/">Sports</a> / <time datetime="2019-11-24T19:03:05-05:00">2 days ago</time>		</footer>
	
	
	
			
<span aria-hidden="true" tabindex="-1" class="article-list__article-mediaicon">
	<span class="article-list__article-mediaicon-svg">
		<svg viewBox="0 0 24 24">
			<path d="M8,5.14V19.14L19,12.14L8,5.14Z" />
		</svg>
	</span>
	</span>
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-index="2"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/sports/middlebury-field-hockey-captures-third-straight-ncaa-title/"
									>
			
				Middlebury field hockey captures third-straight NCAA title
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/sports/">Sports</a> / <time datetime="2019-11-24T18:10:08-05:00">2 days ago</time>		</footer>
	
	
	
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-index="3"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/sports/bu-grinds-out-ot-win-over-vermont-womens-hockey/"
									>
			
				BU grinds out OT win over Vermont women&#8217;s hockey
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/sports/">Sports</a> / <time datetime="2019-11-23T23:55:58-05:00">3 days ago</time>		</footer>
	
	
	
			
<span aria-hidden="true" tabindex="-1" class="article-list__article-mediaicon">
	<span class="article-list__article-mediaicon-svg">
		<svg viewBox="0 0 24 24">
			<path d="M8,5.14V19.14L19,12.14L8,5.14Z" />
		</svg>
	</span>
	</span>
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-index="4"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/sports/norwich-mens-hockey-pushes-past-umass-boston/"
									>
			
				Norwich men&#8217;s hockey pushes past UMass-Boston
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/sports/">Sports</a> / <time datetime="2019-11-23T22:36:09-05:00">3 days ago</time>		</footer>
	
	
	
			
<span aria-hidden="true" tabindex="-1" class="article-list__article-mediaicon">
	<span class="article-list__article-mediaicon-svg">
		<svg viewBox="0 0 24 24">
			<path d="M8,5.14V19.14L19,12.14L8,5.14Z" />
		</svg>
	</span>
	</span>
	</div>

		</article>

			</div>

	<div class="article-list__read-more article-list__read-more--w-arrow">
		<a href="https://www.mychamplainvalley.com/sports/">
			More Sports
							<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
					</a>
	</div>
	
				</section>
				</section>
	
	<!-- Nativo -->
			<div id="native-rr"></div>
	
	<section id="ns-article-bin-31" class="widget widget_ns-article-bin">				<section
					class="article-list article-list--trending"
					data-component=""
					data-context="numbered_list"
				>
					
	<h2 class="article-list__heading article-list__heading--bottom-divider">
		Trending Stories	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-slat"
			data-index="0"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/local-news/missing-chateaugay-teen-found-dead/"
									>
			
				Missing Chateaugay teen found dead
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat"
			data-index="1"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/burlington-shelter-in-urgent-need-of-volunteers-and-donations/"
									>
			
				Burlington shelter issues urgent call for food, volunteers and donations
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat"
			data-index="2"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/local-news/winooski-prepares-to-launch-housing-trust-fund/"
									>
			
				Facing shortage of single-family homes, Winooski plans to launch trust fund
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat"
			data-index="3"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/news/local-news/essex-essex-junction-officials-tackling-property-taxes-for-possible-merger/"
									>
			
				Essex &amp; Essex Junction officials tackling property taxes for possible merger
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat"
			data-index="4"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/aboutus/"
									>
			
				About Us
							</a>
					</h3>
	
	
	
	
	</div>

		</article>

			</div>


				</section>
				</section><section id="ns-article-bin-73" class="widget widget_ns-article-bin">				<section
					class="article-list article-list--story-grid article-list--story-grid--one-col"
					data-component=""
					data-context="headline_list"
				>
					
	<h2 class="article-list__heading">
		SkyTracker Weather Blog	</h2>


<div class="article-list__content">
			
		<article
			class="article-list__article article-list__article--is-stacked article-list__article--has-thumb article-list__article--is-media-type"
			data-index="0"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-and-snow-returns-midweek/"
									>
			
				Weather Blog: Rain and snow returns midweek
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/weather/weather-blogs/">SkyTracker Blog</a> / <time datetime="2019-11-26T17:33:03-05:00">2 hours ago</time>		</footer>
	
	
	
	</div>

	<figure class="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile">
					<a
				href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-and-snow-returns-midweek/"
							>
		
		<div class="article-list__article-image-wrapper">
			
<div class="image-wrapper landscape">
	<img
		src="https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?resize=2560%2C1440&#038;ssl=1"
		alt=""
		srcset="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=320&amp;h=180&amp;crop=1 320w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=640&amp;h=360&amp;crop=1 640w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=960&amp;h=540&amp;crop=1 960w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=1280&amp;h=720&amp;crop=1 1280w, https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?w=1920&amp;h=1080&amp;crop=1 1920w, https://i0.wp.com/www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/11/TOMORROW-4.jpg?resize=2560%2C1440&amp;ssl=1 2560w"
		sizes="(max-width: 899px) 100%, 300px"
	/>
</div>

					</div>

					</a>
			</figure>
			</article>

					
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-index="1"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-rain-snow-moves-in-just-in-time-for-thanksgiving-travel-heres-what-to-expect/"
									>
			
				Weather Blog: Rain &amp; Snow moves in just in time for Thanksgiving travel. Here&#8217;s what to expect.
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/weather/weather-blogs/">SkyTracker Blog</a> / <time datetime="2019-11-26T08:47:11-05:00">10 hours ago</time>		</footer>
	
	
	
	</div>

		</article>

					
		<article
			class="article-list__article article-list__article--is-slat  article-list__article--is-media-type"
			data-index="2"
			data-collection="article-list3"
			data-anvato-params="null"
		>
			
<div
	class="article-list__article-text"
	data-article-list-id="article-list3"
	data-article-text-classes="article-list__article-text"
	data-article-thumb-classes="article-list__article-thumb article-list__article-thumb--is-fullbleed-on-mobile"
	data-current-image-context="[&quot;16:9&quot;,&quot;(max-width: 899px) 100%, 300px&quot;]"
>
			<h3 class="article-list__article-title">
							<a
					href="https://www.mychamplainvalley.com/weather/weather-blogs/weather-blog-finally-warmer-for-a-few-days/"
									>
			
				Weather Blog: Finally warmer for a few days
							</a>
					</h3>
	
			<footer class="article-list__article-meta">
			<a href="https://www.mychamplainvalley.com/weather/weather-blogs/">SkyTracker Blog</a> / <time datetime="2019-11-25T16:34:04-05:00">1 day ago</time>		</footer>
	
	
	
	</div>

		</article>

			</div>

	<div class="article-list__read-more article-list__read-more--w-arrow">
		<a href="https://www.mychamplainvalley.com/weather/weather-blogs/">
			More SkyTracker Blog
							<span class="icon icon--arrow">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 17.938 10.94">
		<path d="M17.944 5.55a.733.733 0 0 1-.032.34v.03c0 .01-.006.01-.008.01a.189.189 0 0 1-.028.05.619.619 0 0 1-.123.17c-.009.01-.013.02-.023.03l-4.927 4.56a.733.733 0 0 1-.5.19.753.753 0 0 1-.54-.23.737.737 0 0 1 .041-1.04l3.547-3.28H.738a.735.735 0 1 1 0-1.47h14.693l-3.74-3.68a.735.735 0 0 1 1.03-1.05l5.022 4.94s0 .01.008.01a.016.016 0 0 0 .017.01.8.8 0 0 1 .163.32c.007.03.009.06.013.09z"/>
	</svg>
</span>
					</a>
	</div>
	
				</section>
				</section><section id="custom_html-41" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="rich-text-cascade"><a class="twitter-timeline" data-width="300" data-height="600" href="https://twitter.com/wvnywfff?ref_src=twsrc%5Etfw">Tweets by Local 22 & Local 44 News</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></section>
	<aside class="ad-unit ad-unit--square ad-unit--sticky">
		<div class="ad-unit__content">
			  <div   id="acm-ad-tag-mr_combo2-mr_combo2"   data-slot='{"pos":"mr_combo2","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[300,250],"sizes":[[[1280,0],[[300,600],[300,250]]],[[1024,0],[[300,600],[300,250]]],[[768,0],[[300,250]]],[[641,0],[[300,250]]],[[0,0],[[300,250]]]],"amp_multi_size":"300x250","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"mr_combo2","tag_id":"mr_combo2","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"mr_combo2","fold":"btf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-mr_combo2-mr_combo2'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>
	<!-- END Ad Unit Square -->
</section><!-- #secondary -->
	</div>

			<aside class="ad-unit ad-unit--leaderboard">
			<div class="ad-unit__content">
				  <div   id="acm-ad-tag-leaderboard3-leaderboard3"   data-slot='{"pos":"leaderboard3","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[320,50],"sizes":[[[1280,0],[[728,90]]],[[1024,0],[[728,90]]],[[768,0],[[728,90]]],[[641,0],[[320,50]]],[[0,0],[[320,50]]]],"amp_multi_size":"320x50","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"btf"}'   data-unit='{"tag":"leaderboard3","tag_id":"leaderboard3","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"leaderboard3","fold":"btf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-leaderboard3-leaderboard3'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  			</div>
		</aside>
	
	
</div><!-- #content -->
		</div>

		<footer id="footer" class="site-footer">
	<div class="site-footer__site-branding">
		<div class="site-footer__logo">
			<a href="https://www.mychamplainvalley.com/" rel="home">
				<img src="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/05/mychamplainvalley_digitalbrand-min.png" alt="WVNY/WFFF" />
			</a>
		</div>
	</div>

		<div class="site-footer__social">
		<h2>Follow Us</h2>
		
<aside class="social-links social-links--default">
	<ul class="social-links__list">
					<li class="social-links__list-item social-links__list-item--facebook">
				<a href="https://www.facebook.com/WVNYWFFF">
					
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 58 58" style="enable-background:new 0 0 58 58;" xml:space="preserve">
	<title>Facebook</title>
	<style type="text/css">
		.facebook-st0{fill:#4267B2;}
		.facebook-st1{fill:#FFFFFF;}
	</style>
	<path class="facebook-st0" d="M54.8,0H3.2C1.43,0,0,1.43,0,3.2v51.6C0,56.57,1.43,58,3.2,58h0H31V35.57h-7.55v-8.78H31v-6.46
		c0-7.49,4.58-11.57,11.26-11.57c2.25,0,4.5,0.11,6.74,0.34v7.83h-4.6c-3.64,0-4.35,1.72-4.35,4.26v5.59h8.7l-1.13,8.78H40V58h14.8
		c1.77,0,3.2-1.43,3.2-3.2l0,0V3.2C58,1.43,56.57,0,54.8,0L54.8,0z"/>
	<path id="f" class="facebook-st1" d="M40,58V35.57h7.57l1.13-8.78H40V21.2c0-2.54,0.71-4.26,4.35-4.26H49V9.1c-2.24-0.23-4.5-0.35-6.75-0.34
	C35.56,8.76,31,12.84,31,20.33v6.46h-7.55v8.78H31V58H40z"/>
</svg>
				</a>
			</li>
							<li class="social-links__list-item social-links__list-item--twitter">
				<a href="https://twitter.com/WVNYWFFF">
					
<svg version="1.1" id="Logo__x2014__FIXED" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 259.77 218.57" style="enable-background:new 0 0 33 33;" xml:space="preserve">
	<title>Twitter</title>
	<style type="text/css">
		.twitter-st0{fill:none;}
		.twitter-st1{fill:#1DA1F2;}
	</style>
	<g>
		<rect x="-69.49" y="-90.72" class="twitter-st0" width="400" height="400"/>
		<path class="twitter-st1" d="M84.13,210.87c94.34,0,145.94-78.16,145.94-145.94c0-2.22-0.05-4.43-0.15-6.63
			c10.01-7.24,18.72-16.27,25.59-26.56c-9.19,4.08-19.08,6.83-29.46,8.07c10.59-6.35,18.72-16.4,22.55-28.37
			c-9.91,5.88-20.89,10.15-32.57,12.45c-9.36-9.97-22.69-16.21-37.44-16.21c-28.33,0-51.3,22.97-51.3,51.29
			c0,4.03,0.45,7.94,1.33,11.69C86,68.53,48.2,48.12,22.91,17.09c-4.41,7.58-6.95,16.39-6.95,25.78c0,17.8,9.06,33.5,22.82,42.69
			c-8.41-0.26-16.32-2.57-23.23-6.42c-0.01,0.21-0.01,0.43-0.01,0.65c0,24.84,17.68,45.58,41.15,50.28c-4.31,1.17-8.84,1.8-13.52,1.8
			c-3.3,0-6.52-0.33-9.64-0.93c6.53,20.38,25.46,35.21,47.92,35.62c-17.56,13.76-39.67,21.96-63.7,21.96
			c-4.14,0-8.22-0.24-12.24-0.71C28.21,202.38,55.16,210.87,84.13,210.87"/>
	</g>
</svg>
				</a>
			</li>
							<li class="social-links__list-item social-links__list-item--instagram">
				<a href="https://www.instagram.com/local22local44/?hl=en">
					<img src="https://www.mychamplainvalley.com/wp-content/themes/nexstar/client/src/images/footer/social/instagram.png" alt="Instagram" />
				</a>
			</li>
													<li class="social-links__list-item social-links__list-item--email">
				<a href="mailto:news@mychamplainvalley.com">
					
<svg xmlns="http://www.w3.org/2000/svg" width="29.35" height="22" viewBox="0 0 29.35 22">
	<title>Email</title>
	<defs>
		<style>
			.email-cls-1 {
				fill: #eb6823;
				fill-rule: evenodd;
			}
		</style>
	</defs>
	<path class="email-cls-1" d="M1168.41,189.824a0.347,0.347,0,0,1,.56.269v11.719a2.75,2.75,0,0,1-2.75,2.751h-23.84a2.75,2.75,0,0,1-2.75-2.751V190.1a0.338,0.338,0,0,1,.55-0.269c1.29,1,2.99,2.263,8.83,6.51,1.21,0.882,3.25,2.739,5.29,2.727,2.04,0.017,4.12-1.879,5.29-2.727C1165.43,192.093,1167.13,190.821,1168.41,189.824Zm-14.11,7.4c1.33,0.023,3.24-1.674,4.2-2.373,7.61-5.518,8.19-6,9.94-7.375a1.381,1.381,0,0,0,.53-1.083v-1.089a2.75,2.75,0,0,0-2.75-2.75h-23.84a2.75,2.75,0,0,0-2.75,2.75V186.4a1.359,1.359,0,0,0,.53,1.083c1.75,1.37,2.33,1.857,9.93,7.375,0.96,0.7,2.88,2.4,4.21,2.373h0Z" transform="translate(-1139.62 -182.562)"/>
</svg>
				</a>
			</li>
			</ul>
</aside>
	</div>
	
		<div class="site-footer__apps">
		<h2>News App</h2>
		<div class="app-links">
							<div class="app-link">
					<a href="https://apps.apple.com/us/app/fox44-abc22/id643325314">
						<img src="https://www.mychamplainvalley.com/wp-content/themes/nexstar/client/src/images/footer/app-stores/appstore_footer.png" alt="Get the iOS app" />
					</a>
				</div>
										<div class="app-link">
					<a href="https://play.google.com/store/apps/details?id=com.newssynergy.wvny&#038;feature=search_result#?t=W251bGwsMSwxLDEsImNvbS5uZXdzc3luZXJneS53dm55Il0.">
						<img src="https://www.mychamplainvalley.com/wp-content/themes/nexstar/client/src/images/footer/app-stores/googleplay_footer.png" alt="Get the Android app from Google Play" />
					</a>
				</div>
					</div>
	</div>

	
<div class="site-footer__primary-nav">
	<div class="menu-new-footer-primary-container"><ul id="menu-new-footer-primary" class="menu"><li id="menu-item-92842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92842"><a href="https://www.mychamplainvalley.com/news/">News</a></li>
<li id="menu-item-92843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92843"><a href="https://www.mychamplainvalley.com/top-video/">Top Video</a></li>
<li id="menu-item-92844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92844"><a href="https://www.mychamplainvalley.com/weather/">Weather</a></li>
<li id="menu-item-92845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92845"><a href="https://www.mychamplainvalley.com/sports/">Sports</a></li>
<li id="menu-item-92860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92860"><a href="https://www.mychamplainvalley.com/brit-unscripted/">Brit Unscripted</a></li>
<li id="menu-item-92846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92846"><a href="https://www.mychamplainvalley.com/story-idea/">Story Idea</a></li>
<li id="menu-item-92859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92859"><a href="https://www.mychamplainvalley.com/aboutus/">About Us</a></li>
</ul></div></div>

<div class="site-footer__secondary-nav">
	<div class="menu-new-footer-secondary-container"><ul id="menu-new-footer-secondary" class="menu"><li id="menu-item-92852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92852"><a href="https://www.mychamplainvalley.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-92851" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92851"><a href="https://www.mychamplainvalley.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-92853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92853"><a href="https://www.mychamplainvalley.com/aboutus/advertise-with-us/">Advertise with Us</a></li>
<li id="menu-item-92850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92850"><a href="https://www.mychamplainvalley.com/aboutus/wvny-wfff-closed-captioning/">WVNY &#038; WFFF Closed Captioning Information</a></li>
<li id="menu-item-161217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161217"><a href="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/06/WFFF-EEO-Report-_OP_2_CP__1543605918698_63686253_ver1.0.pdf">WFFF EEO Report</a></li>
<li id="menu-item-92854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-92854"><a href="https://www.mychamplainvalley.com/disability-assistance-for-public-file/">Disability Assistance for Public File</a></li>
<li id="menu-item-161215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161215"><a href="https://www.mychamplainvalley.com/wp-content/uploads/sites/61/2019/06/NexstarCCCertification.pdf">Nexstar CC Certification</a></li>
<li id="menu-item-161220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161220"><a href="https://publicfiles.fcc.gov/tv-profile/wfff-tv">WFFF Public File</a></li>
<li id="menu-item-161221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161221"><a href="https://publicfiles.fcc.gov/tv-profile/wvny">WVNY Public File</a></li>
</ul></div></div>

	<div class="site-footer__network-branding">
								<a href="https://www.nexstar.tv" title="Go to Nexstar">
				<img src="https://www.mychamplainvalley.com/wp-content/themes/nexstar/client/src/images/footer/nexstar-logo-white-nmg.png" alt="LAKANA">
			</a>
			</div>
	<div class="site-footer__copyright">
		&copy; 1998 - 2019 Nexstar Broadcasting, Inc. | All Rights Reserved.	</div>
</footer>
	</div><!-- #page -->

	
<script type='text/javascript'>
(function() {
	var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});

	_sf_async_config.sections = "SkyTracker Blog";
	_sf_async_config.authors = "Amanda Thibault";
	function loadChartbeat() {
			var e = document.createElement('script');
			var n = document.getElementsByTagName('script')[0];
			e.type = 'text/javascript';
			e.async = true;
			e.src = '//static.chartbeat.com/js/chartbeat.js';
			n.parentNode.insertBefore(e, n);
	}
	loadChartbeat();
})();
</script>

	<aside class="ad-unit ad-unit--adhesion">
		<div class="ad-unit__content pre-render">
			<div class="close-btn-container">
				<div class="close-btn" aria-label="Close Viewport Adhesion Ad">&times; Close Ad</div>
			</div>
			  <div   id="acm-ad-tag-adhesion-adhesion"   data-slot='{"pos":"adhesion","is_companion":true,"is_oop":false,"refresh_on_resize":true,"size":[320,50],"sizes":[[[1280,0],[[728,90]]],[[1024,0],[[728,90]]],[[768,0],[[728,90]]],[[480,0],[[320,50]]],[[0,0],[[320,50]]]],"amp_multi_size":"320x50","lazyload":false,"wx_targeting":[],"module_refreshable":false,"fold":"atf"}'   data-unit='{"tag":"adhesion","tag_id":"adhesion","dfp_id":"5678","tag_name":"nx.wfff","ad_disabled":"0"}'   data-targeting='{"pos":"adhesion","fold":"atf","category":"skytracker_blog","kw":"weather-blog-rain-and-snow-returns-midweek"}'   data-path='/5678/nx.wfff/weather/skytracker_blog'  ></div>  <script>  (function () {   try {    var event = new CustomEvent(     "nsDfpSlotRendered",     {      detail: {       id: 'acm-ad-tag-adhesion-adhesion'      }     }    );     window.dispatchEvent(event);   } catch (err) {}  })();  </script>  		</div>
	</aside>

	<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201948'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpApiSettings = {"root":"https:\/\/www.mychamplainvalley.com\/wp-json\/","nonce":"135d60e68c","versionString":"wp\/v2\/"};
/* ]]> */
</script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://www.mychamplainvalley.com/_static/??-eJydjEkSgyAQAD8UAQU0HlJ5ywwzJFiIhqWS50ePueba1d3yvXchudiIi1yKhD10mV+NSxVrSGIpF3kobkuVU5X1yeshJv6UClm6GE6KLUQ660fcEKIgZYwmA6CuXimPM8AgsCWK/McUcg3uKLUdekLLZHGc/GR71P73el9vvZ3MqEc9m+UL+exMVA=='></script>
<script type='text/javascript' async src='https://s7.addthis.com/js/300/addthis_widget.js?ver=1.0#pubid=ra-5b7190c0239b8829'></script>
<script type='text/javascript'>
var addthis_config=addthis_config||{};addthis_config.data_track_addressbar=false;addthis_config.data_track_clickback=false;
</script>
<script type='text/javascript' src='https://www.mychamplainvalley.com/wp-includes/js/wp-embed.min.js?m=1571091490g'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201948.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'162794653',post:'162306',tz:'-5',srv:'www.mychamplainvalley.com'} ]);
	_stq.push([ 'clickTrackerInit', '162794653', '162306' ]);
</script>

</body>
</html>
